What browsers are compatible with GetResponse?

GetResponse supports the latest official versions for any of the following browsers: Mozilla Firefox (recommended), Google Chrome (recommended), Safari, or Internet Explorer. For best results, any browser used should be fully up to date and include plugins that allow Flash technology, JavaScript, and “cookies”.

Any browser not listed above is unsupported. Older browsers may experience performance issues within our editors and other features.